Need help?


Search OutdoorKing by entering Key Words Below



Who's Online Now
0 members (), 185 guests, and 195 robots.
Key: Admin, Global Mod, Mod
Online Spare Parts


Online Store


Newest Topics
What Colour Was the Old Power Torque Mufflers?
by Jeffery - 16/06/24 08:30 AM
Victa Pro 550 Mulch
by Jeffery - 26/05/24 07:43 PM
Husqvarna Rancher 50 Oil Vent
by MowingManiac - 18/05/24 11:23 AM
Victa: The Triplets
by Polybus - 13/05/14 08:28 PM
Topic Replies
What Colour Was the Old Power Torque Mufflers?
by maxwestern - 17/06/24 07:40 PM
Husqvarna Rancher 50 Oil Vent
by MowingManiac - 07/06/24 01:05 PM
Victa Pro 550 Mulch
by Bruce - 03/06/24 11:01 PM
Victa: The Triplets
by maxwestern - 30/05/24 10:40 PM
Previous Thread
Next Thread
Print Thread
Rate Thread
Hop To
#112211 30/05/21 06:28 PM
Joined: May 2021
Posts: 16
Novice
Hello all I am a first time participant having recently acquired a Morrison 400. It has a QPE55 engine. Third time mowing and the blades stopped engaging. Investigation showed a broken drive shaft just where it connects to the clutch drive assembly . Any suggestions would be appreciated Paul

SilverLeaf #112213 30/05/21 08:26 PM
Joined: Nov 2013
Posts: 6,938
Likes: 278
Forum Historian
Hello SilverLeaf
That doesn't sound too good.

I think we need some images to understand this.

------------------------
Jack

SilverLeaf #112217 30/05/21 09:03 PM
Joined: Sep 2015
Posts: 2,052
Likes: 146
SENIOR TECHNICIAN & HISTORIAN
G'day Paul and Jack I've seen a couple of these new engines with damaged pto shafts when basically brand new ,both machines were taken back to the place of purchase for a full refund, otherwise it may be worth getting in contact with Consumer Affairs. The engines that I looked at were on Wood Chippers ,the drive assembly coming loose on the crank on first use and not an operator misusing the equipment. If it's damaged from the third time of use and hasn't been damaged from misusing the equipment ,I would contact the supplier for a free repair , replacement or full refund. Cheers Max.

maxwestern #112218 31/05/21 10:24 PM
Joined: May 2021
Posts: 16
Novice
Thanks Max I should have made it clear that while the failure happened on my third mow, I am the latest owner of an old machine. See attached photo of the end pop the broken drive shaft. Suspect it will mean a replacement shaft or perhaps new motor. Cheers Paul

Attached Images

Moderated by  bigted, Bruce, CyberJack, Mr Davis 

Link Copied to Clipboard
ShoutChat
Comment Guidelines: Do post respectful and insightful comments. Don't flame, hate, spam.
Newest Members
TheGreyRider, viv5038, big hello aye, JACWEL, Mike Horsman
16,811 Registered Users
Forum Statistics
Forums145
Topics12,719
Posts104,666
Members16,812
Most Online2,545
Dec 23rd, 2019
OutdoorKing Showcase
20 Bucks from FB Marketplace
20 Bucks from FB Marketplace
by Return Rider, February 20
Victa Cortina 2 Shed Find
Victa Cortina 2 Shed Find
by Return Rider, January 25
My Rover Baron 45
My Rover Baron 45
by Maxwell_Rover_Baron, April 16
SHOWCASE - Precision Mowers - 2021
SHOWCASE - Precision Mowers - 2021
by CyberJack, April 14
SHOWCASE – Atco Rotary – Paul C - 2020
SHOWCASE – Atco Rotary – Paul C - 2020
by CyberJack, December 28
HOME |CONTACT US
Powered by UBB.threads™ PHP Forum Software 7.7.5
(Release build 20201027)
Responsive Width:

PHP: 7.4.33 Page Time: 0.017s Queries: 24 (0.012s) Memory: 0.6769 MB (Peak: 0.7089 MB) Data Comp: Zlib Server Time: 2024-06-17 21:12:05 UTC
Valid HTML 5 and Valid CSS